Skip to content
DnsLister Forum

Where domain hunters compare notes

Hey all

I am not what you would call a power user; definitely more in the category of "know just enough to get in trouble." I've been using Technitium for about 6 months, and it's worked fine; set it up on my living room computer (Linux Mint) as the DNS server for my other two computers. I've also been using this computer as a web server via apache2, and it's attached to the living room TV.

Last night I did something that I don't think is the cause of all this but since it's coincidental I'm including it. I tried to set up a self-signed openssl cert so I could use the webserver with https. This worked exactly one time, and then it gave an error, something like "file too long." Didn't wanna fight it, it was late and http still worked, so I went to bed.

Woke up this morning, and none of my computers could get online. Turns out the server had crashed — still powered on but wouldn't display anything. I hard reset the server, and suddenly Technitium isn't running on it.

Okay, so there's the setup. Now here's the actual issues:

  1. I changed the DNS servers that my other computers use back to Cloudflare (1.1.1.1), so they can still get online; that's how I'm talking to you now. But for some reason I can't do the same for the server. Did Technitium change something in the settings that I can't see?

  2. What can I do to get Technitium back up and running? I can't even find its .service file.

  3. Failing that, what do I have to do to remove it from my server?

Source: r/technitium · by /u/freswinn

Leave a Reply

Your email address will not be published. Required fields are marked *